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ZPP-C194-123 SparroWatch USB Datalink Installation & Operating Instructions
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Introduction:
These instructions describe how to install the SparroWatch USB Datalink (ZPP-C282-439) on your PC.

PC Requirements:
Windows 2000, NT, ME, or XP
256 MB (256,000 KB) RAM minimum
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Installation Instructions:

1. If an earlier version of SparroWatch is already installed on the PC,
uninstall it using “Settings> Control Panel > Add/Remove Programs”.

2. Close all other Windows applications.

3. Insert the SparroWatch Installer CD into the CD/DVD drive.

Install SparroWatch:

1. Click Start > Run

2. Set “Files of type” to “All Files”, then browse to D:\ SPW_XXXX.msi.

Laak in: I.ﬁJ Sparrate/atch (D) j = £ ER-

Hizstaory
@&

1
| e
=

usbdic.inf

L-_E. ZPP-C194-123 SparroWatch USE Datalink: Instructions 4. doc

iy Docurments

File name: |sPw_2.9.32msi | Open |
j Canicel |
.

Filez of type: I.-i‘-.ll Files

3. Click the Open button, then the OK button.
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4. Click the Next button.

ji# SparroWatch

Welcome to the Sparrowatch Setup
Wizard

The inztaller will guide you through the steps required to inztall S paro'sf atch on your computer.

Click "Mest" to continue.

WARMIMNG: This computer program is protected by copyright law and international treaties.
Unauthorized duplication or distibution of thiz program, or any partion of it, may result in severe
civil or criminal penalties, and will be progecuted ta the makimunm extent pozzible under the law.

Cancel Brewious

5. Click the Next button.

fi SparroWatch -10] x|

Select Installation Folder

The installer will install S parraiadatch in the fallawing falder.

Ta inztall in this falder, click "Mext". Ta install to a different new ar existing folder, enter one
below ar click “Browse".

Folder: C:AProgram FileshSparroiwfatch’ Browse. .. |

Y'ou can install the saftware an the following drives:

Volume | Disk Siz
== I7GE

1] | i

Dizk Cost... |

Cancel Freviouz |
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6. Click the Next button.

i'-‘% SparroYatch

Confirm Installation

The ingtaller is ready to install Sparrcisfatch on your computer.

Click "Mest" ta start the installation.

LCancel Previous

7. The installer should display the following window to confirm that SparroWatch has been successfully installed.
If this window is displayed, click the Close button. If not, go back to step 1 of “Install SparroWatch”.

i'._wz,l SparroWatch

Installation Complete

Sparrotatch has been sucessfully inztalled.

Click "Cloge' to exit.

Cancel Erevious
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4. Connect the USB connector to one of your PC’s USB ports as shown below.

5. A “Found New Hardware Wizard” window should open on your PC.
Select “No, not this time”, then click the Next button.

Found Mew Hardware Wizard

Welcome to the Found New

% Hardware Wizard
Windows will zearch for curent and updated software by
looking on pour computer, on the hardware ingtallation CO, or on
the “windows pdate Web zite [with pour permizzion).

Fead our privacy policy

Can Windows connect ta Windows Update to search for
zoftware?

" Yes, thiz time orly

™ Yes, now and every time | connect a device

Click Mest to continue.

< Back I Hest = I Carnicel
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6. Select “Install the software automatically”, then click the Next button.

Found MNew Hardware Wizard

5

Thiz wizard helps you install software faor:

LSE Datalink [4F5 2004 Inc)

{ .'\J If your hardware came with an installation CD

.

=2 or floppy dizk. inzert it now.

What do ol want the wizard bo do?

¥ {nstall the zoftware automatically [Fecommended)

{7 Install from a list or specific location [Advanced)

Click Mest to continue.

< Back I Mest » I Cancel

7. If the message below is displayed, click on the “Continue Anyway” button.

Hardware Installation

' E The saftware you are installing far thiz hardware:
[ ]
USE Datalink [4FS 2004 Ine)

has not pazzed Windows Logao kesting ta werify its compatibility
with “windows =P, [Tell me why thiz testing is important. |

Continuing your installation of thiz zoftware may impair
or destabilize the correct operation of pour spztem
either immediately or in the future. Microzoft strongly
recommends that you stop thiz installation now and
contact the hardware vendor for zoftware that has
pazzed Windows Logo testing.

LConfinue Anyway
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8. The Wizard should then display the following confirmation window.
If the window below is displayed, click the Finish button.
If the USB Datalink driver does not install successfully, unplug the USB Datalink and go back to step 1.

Found MNew Hardware Wizard

Completing the Found New
% Hardware Wizard

3

_\> LUSE Datalink [AF5 2004 Inc)

Windows has finizhed installing the zoftware for this device.

To cloge thiz wizard, click Finizh.

< Black

Caneel |

9. Make a note of which USB port you used for the driver installation. You either need to use the same port each
time you connect the datalink, or repeat the driver installation for each port that you expect to use.

10. Open SparroWatch. When the “Enter Product ID Code” window appears, enter the Product ID code supplied
to you by your distributor or Zenith.

If you do not have a Product ID Code, contact your distributor or Zenith (276/669-5555) and request one.

x
Enter the Product I distributed with the license

agreement far thiz progran.
Canzel

This completes your SparroWatch installation. SparroWatch is now ready to be used. Refer to the “Operating
Instructions” on the next page if needed.
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Operating Instructions:

1.  Install the datalink box and communications cable.
e Remove the dust cap from the 4-pin datalink connector on the wiring harness.
e Connect the datalink to the 4-pin connector on the wiring harness.
e  Connect the USB connector to an USB port on your PC. Make sure that you use a port that has the USB
Datalink driver installed.

2. Open SparroWatch by double-clicking on the SparroWatch short-cut on your PC’s desktop.

AdF
t

SparroWatch.Ink
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3. Configure SparroWatch for your PC.

e  C(Click “Options” > “Preferences” on the SparroWatch menu. The “Preferences” window below should appear.
e  Click the “Detect and Auto-Configure USB Datalink” button.

-l

Communications Port Product D Code
|COMT |
Current Program Application:  Sparotaatch ECMAZS
| I_ USE ISEH 423[' FEISt Initializatil:ln | Eurrent F'r-:u:iuct |D EDEIEZ Bl"."IE HD"\"IED{SEHGHCH
| Timeouts: [ 1000 TimeoutTick: [~ 10 | (Enter New Product |D Code
| [ Enable 2 zecond time delay for serial port wake upl File Menu Recent Files

Restore Defaulk Settingz

@ 10400bps € 30400 bps |

| [T T and P lines de-echoed [advanced) | Clear Recent File Lizt

I1SE Datalink Configuatian Language
| [ Use USE Datalink |

|Espaﬁu:u|
Detect and Auto-Configure USE Datalink

k. | Cancel

4. SparroWatch should display a window indicating which COM port it selected.

#F sparroWatch x|

Selecting USBE Datalink registered to port COM4
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5.  Your Preferences window should then look similar to the one shown below. Your PC will probably have
a different COM port selected.

I

Communications Port Froduct [ Code
|Coms |
Current Program Application:  Sparotaatch ECMAZS
| Ii USE ISEH 423[' FEISt Initializatil:ln | Eurrent F'r-:u:iuct |D EDEIEZ Bl"."IE HD"\"IED{SEHGHCH
| Timeouts:; | 1000 Timeout Tick: | 10 | Enter Mew Product ID Code
| [ Enable 2 zecond time delay for serial port wake upl File Menu Recent Files

| C 10400bps (% 38400 bps | Restore Defaulk Settingz

| [® Tx and P lines de-echoed [advanced) | Clear Recent File Lizt

I1SE Datalink Configuatian Language
| B¢ Use USE Datalink |

. : |Espaﬁu:u|
Detect and Auto-Configure LISE Datalink:

k. | Cancel

10
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6. Verify that the ECM is communicating with SparroWatch.

e Turn on the power to the ECM.

e  Click on the light bulb in the lower right corner of the SparroWatch window or press the F9 key. The light will
turn yellow if SparroWatch is communicating with the ECM.

If the light bulb does not turn yellow, verify the following:
e  The USB datalink connections between the PC and ECM is good.
e 12 VDC is getting to pin A of the 16-pin female connector and pin 2 of the ECM.

Once SparroWatch is communicating with the ECM, you can use SparroWatch to program, monitor, calibrate, or
retrieve diagnostic codes from the ECM. These features are discussed in the following sections.

“E sparroWatch Default.szl [Unmodified] - [System ¥ariables] ;Iglil

File Wiew Diagnostics ECM Options Help

EI--E_CM [rata List summaw

 Ram Sansors Engine Speed 17985 RPM  ([Last Injector Pulse 'Width 0.000 ms

i Gwnitohes tanifold Absolute Fressure 448 kPa Abs [Cpen/ Closed Loop Status, Bank 1 CLOSED
Engine Coclart Temperature 913 g Short Term Fuel Trim, Bank 1 0.026 factor
MIL Lamp OFF Long Term Fuel Trim, Bank 1 1.109 factor
STOF Lamp OFF 02 Sensor “aoltage, Bank 1 Sensor 1 0.707 v
Engine Protection Status oK Desired Engine Speed 1800.0 RPM
Intzke i Temperature 392 k' Desired Manifold Pressure 445 kPa Abs
Gasecus Fuel Tempersture 773 g Final Cormmand Tarque [Normalized) 0.395 factor
Hey Fower Yoltage 14 .125 v Engine Torque Estimate 376 MNm
Barometric Pressure 911 kPa Abs [Engine Power Estimate 7.0 KW
Final Accelerator Padal Position 0.000 factor [Cil Fressure Status DK
Desired Throttle Position 0.136 factor [Selected Fuel LPS
Firal Throttle Position 0.131 factor |[Fuel Trim Valve Duty Cycle 0.000 factor
Firal Ignition Timing 29 1 SBTDC [Total Engine Run Time 39632 h
| I v

Viewer [F2] | Editor [F3] | LogiGraphF4 | SetupiCal Fa] | DTG [FA] J | | |25

11
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SparroWatch Tabs
The SparroWatch tabs allow you to use SparroWatch to view, edit, log/graph variables, or retrieve diagnostics
information from the ECM. The tabs are located across the bottom of the SparroWatch window.

Viewer [F2]

Click on the Viewer tab at the bottom-left corner of the SparroWatch window or type “F2”.

There are three monitor screens: “Summary”, “Raw Sensors”, and “Switches”. Click on the screen that you
want to use.

Editor [F3]
OEM customers can edit the engine speed settings by clicking on the Editor tab or typing “F3”.
The speed settings that can be edited are detailed at the end of this document.

Log/Graph [F4]
The Log/Graph utility is useful for troubleshooting intermittent problems. If you need assistance using this
utility, contact Zenith for instructions.

Setup/Cal [F5]
Normally, you should not need to use any of the features in Setup/Cal unless requested to do so by Zenith
personnel.

DTC [F6]
To retrieve Diagnostic Trouble Codes (DTC) click on the DTC tab or type F6.

There are three status levels for the trouble codes, which are listed in the table below.

Fault Status Meaning

Current Faults Fault that caused the code is still occurring.

Faults this key cycle Fault occurred earlier this key cycle, but is not occurring now
Previous or History Faults Fault occurred on a previous key cycle, but is not occurring now.

Contact Zenith if you need assistance interpreting the DTC or correcting the problem that caused the DTC.

12
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6. SparroWatch Menu
Use the SparroWatch menu to retrieve or save calibration files, program the ECM, or clear trouble codes. The
commonly used menu items are documented below.

File > Open Calibration from Disk
Loads a calibration file into SparroWatch (not the ECM).

File > Save Calibration to Disk
Saves the calibration in SparroWatch to a file on your PC.

Action > Display Current Diagnostic Trouble Codes (Cntrl+D)
Displays current trouble codes (same as clicking on the DTC tab or typing F6).

Action > Clear Diagnostic Trouble Codes (Shift+F12)
Clears the trouble codes in the ECM’s memory. If a fault is active, the ECM will store the trouble code
again.

ECM > Read ECM Calibration Tables
Uploads the calibration tables from the ECM to the PC. Use this if you want to see the calibration that is
stored in the ECM.

ECM > Send Calibration Tables to Temporary ECM RAM

Downloads the calibration from SparroWatch to the ECM. The calibration will be downloaded to the ECM’s
temporary memory (RAM). The calibration will be lost when the ECM is turned off, unless the calibration is
saved to Flash memory.

ECM > Send and Save Calibration Tables to Permanent ECM FLASH

Downloads the calibration from SparroWatch to the ECM and saves it in the ECM’s “permanent” FLASH
memory. This command is equivalent to “Send Calibration Tables to Temporary ECM RAM” and then
“Save ECM RAM to Permanent FLASH Memory”.

ECM > Save ECM RAM to Permanent FLASH Memory

Saves the calibration that is stored in temporary ECM RAM to “permanent” FLASH memory. This means
that the calibration will be retained until it is overwritten with another calibration. FLASH memory will retain
the calibration data when the ECM is turned off.

ECM > Read ECM/Firmware Version
Reads the version of the program that is stored in the ECM.

ECM > Reset ECM
This causes the ECM to do a “soft” reset, similar to a quick key-off/key-on. It is not necessary to reset the
ECM unless requested to do so by Zenith personnel.

ECM > Program ECM/Vehicle Serial Numbers
Zenith programs the ECM and engine serial numbers. The OEM or End customer can program the
“Customer Note”.

ECM > Program Firmware

Downloads a new program to the ECM and saves it in permanent (FLASH) memory. This should only be
done when requested by Zenith personnel. After downloading a new program to the ECM, it is usually
necessary to download and save a new calibration file.

13
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Options > Preferences
The Preferences screen is discussed in Step 3 of the Operating Instructions.

If SparroWatch and the ECM communicate reliably at 10400 bps, you may be able to speed
communications by going to 38400 bps. This mainly will speed programming the ECM and
uploading/downloading calibration files. You can try 38400 bps by clicking on the 38400 button. If the
SparroWatch-ECM communications becomes unreliable, go back to 10400 bps.

i

Comnunications Pork Product |0 Code

 ®COM1 OCOM2 OCOM3 OCOM4 |

Current Program Application:  Sparotwatch ECMAZS
| [ Use 15014230 Fast |nitislization | Current Product 1D Code: qdgE " drgx g1 mEPn

| Timeouts: | 1000 Timeout Tick: | 10 |

| [T Enable 2 zecond time delay for senal port wake up|

| [T Tx and Fx lines de-echoed [advanced) |

Enter Mew Product ID Code

|r‘ 10400 bps

File Menu Recent Files Language

Restare Defaulk Settings

| Ezpafiol
Clear Recent File List

(] | Cancel

14
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7. Calibration Parameters

The following procedure should be used for making calibration changes. Failure to follow this procedure
could result in incorrect engine operation.

1. Upload the calibration from the ECM into the PC.
(ECM > Read ECM Calibration Tables)

2. Modify the calibration as needed.

3.  Download the calibration from the PC to the ECM and save it in the ECM’s permanent FLASH memory.
(Send and Save Calibration Tables to Permanent ECM FLASH)

4.  Save a copy of the calibration changes on your PC.
(File > Save Calibration to Disk)

The following is a list of the calibration parameters and how to calibrate them.

PTO Speed List:

This calibration parameter determines the RPM setpoint based on the Speed Select 1, 2, and 3 inputs on the male
16-pin connector. A “0” indicates an OFF state, and a “1” indicates an “ON” state. Typically, ONis 12 VDC, and
OFF is 0 VDC. Zenith can define ON to be 0 VDC and OFF to be 12 VDC if required.

7 SparroWatch HGM_H410_NG_0OL.d02 A25-2006-10-20.BI_.szl [Modified] - [Table Editor] ;EE[EI
File View Action Diagnostics ECM Options Help
['="EcM calibration Tables PTO Speed List
= Spamow Configuration Urits = None Uniis = =
2 Power Take Off IY Speed Select Input I |
PTO Spead List 3 2 1
FPTO Speed v, Speed Contr 18000 40 0 0
PTO Set Speed Ramp Up R. 1900.0] 0O 0 1
-PTO Set Speed Ramp Do 2000.0 0 1 0
~ Calibration Hotes z1oo.a0| O 1 1
zzoo.o| 1 0 0
2300.0| 1 0 1
2400.0 :]] :]] (1)
I = | | ﬂ 2500,
Mewer [F2] Editor [F3] Leg/Graph [F4] Setup/Cal [F) OTC [Fé] @

15
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PTO Speed vs. Speed Control Input:

This function defines the relationship between “Speed Control Pot Signal” (pin R on the female 16-pin connector)
and the RPM setpoint. The X input is the Speed Control Pot voltage scaled between 0 and 1. The Y output is the
RPM setpoint.

w7 SparroWatch HGM_H410_NG_0L.d02 AZ25-2006-10-20.B1_.szl [Unmaodified] - | Table Editar] - |EI|5|
Eile Wiew Action Diagnostics ECM  Cptions  Help
B ECM Calibration Tables PTO Speed vs. Speed Control Input
B Sparrow Configuration - - -
& Poveer Take Off Unitz = Mone IY Units = factor Pata Unit= = Pk I I
L PTO Speed List
FTO Speed vs. Speed Contr 0.000 10000
PTO Set Speed Ramp Up R, WG L0000
- PTO Set Speed Ramp Down 0. @50 =000, 0
- Calibration Hotes 1 ooo 2000, 0
1.000 20000
1.000 2000.0
1.000 F000.0
l.000 F000.0
1.000 I0ao.o
4 I I LI 1.000 I0ao.o
“ewer [F2] L Editar [F3] 1 LogsGraph [F] l SetupsCal [F5] l DTG [F&] Jl | @

PTO Set Speed Ramp Up Rate:
This calibration parameter defines how quickly the RPM setpoint ramps up (RPM/sec) when controlling RPM with
an increment/decrement switch.

e sparroWatch HGM_H410_NG_0L.d0Z AZ5-2006-10-20.B1_.szl [Modified] - [Table Editor] = | Ellil
File ‘Wiew Ackion Diagnostics ECM  Options  Help
E|--E_I3I‘u1 Calibration Tables PTO Set Speed Ramp UP Rate

B- Sparram Configuration
él--F'u:uLnuer Take Off
- PTO Speed List
FTO Speed ws. Speed Contr
®FTO Set Speed Ramp Up R
LPTO Set Speed Ramp Down
- Galibration Notes

d | W

“dawer [FZ] Editar [F3] Log#Graph [F4] SetupdCal [F5] OTC [F&] o

Lnitz = Mone IY Lnitz = Mone Pata Units = HF‘MISI

lo0.0
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PTO Set Speed Ramp Down Rate:
This calibration parameter defines how quickly the RPM setpoint ramps down (RPM/sec) when controlling RPM
with an increment/decrement switch.

#F sparroWatch HGM_H410_NG_0L.d02 A25-2006-10-20.BI_.szl [Modified] - [Table Editor] = I I:Ilil

File Wiew Action Diagnostics ECM  Cptions Help

= ECM Calibration Tables PTO Set Speed Ramp Down Rate

B- Sparraw Configuration Unit N Ut M ot Lnt =TT,
é--inerTake O N = Mone IY N = Mone P a Llnits = SI I

i+ PTO Speed List
FTO Speed vs. Speed Contr

lo0.0

- Calibration Hotes

/| | H

“dewer [F2] L Editar [F3] l Log/Graph [F4] 1 SetupsCal [F5] l DT [F6] JI |@

Calibration Notes:
You can record your comments about the calibration changes in the “Calibration Notes”. It is a good idea to note
what you changed, when, and why.

% gparro¥atch Dummy calibration file.SZL [Modified] - [Table Editor] ;|g|5|
File Miew Ackion Djagnostics ECM  Options  Help
E|--E_l3ru1 Calibration Tables Calibra‘tiun Nutes
B Sparrow Configuration -
& Poveer Take Off File Name: Cummy calibration file S7L
P70 Speed List Date Modified: 10/26/06
(- FTO Speed ws, Spaed Contr
- PTO Set Speed Ramp Up R.[Modified By: Dave Morris
LPTO Set Speed Ramp Down
- Calibration Notes Fev d01 Date: 10/13/06 By Dawe Morris -

Initial calibration for customer X2,

Rey d02 Date 10/23/06 By A7
Adjusted EPM setpoints for the Lone Wolf installation.

(| | © [

“ewer [F2] L Editar [F3] 1 LogsGraph [F] l SetupsCal [F5] l DTC [F5] Jl |@
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